
Math 5335 Fall 2018 Lab #0: Installing and using GeoGebra

This semester you will have a number of “lab assignments” which require you to use GeoGebra, a dynamic
geometry program. GeoGebra lets you explore geometric ideas and constructions on your computer. It’s free and
will run on Windows, Macintosh or Linux computers. There are also iOS and Android versions you can run on phones
or tablets, but this handout will assume you are using the “Desktop” version on a desktop or laptop computer. If
you use a different version you may have to explore a bit to find the appropriate menus and commands.

The instructions below show you how to install GeoGebra and use some of the tools you’ll need to complete your
homework assignments. The GeoGebra website has extensive documentation and is a good resource if you need to
look something up. There is a short assignment at the end of this handout which is due Wednesday, September
12 by class time. Make sure you try working with GeoGebra before then; don’t wait until class on Wednesday to
tell me, “I had trouble installing the program.” Any technical problems should be discussed with me by Monday
at the latest.

1. Installing GeoGebra

Use a web browser to go to http://www.geogebra.org to find links and instructions for installing GeoGebra on
your device. In a pinch, you can choose Graphing Calculator or GeoGebra Classic to run GeoGebra within the
browser, but I highly recommend you use the links at https://www.geogebra.org/download to install GeoGebra
for offline use.

Past experience suggests you might want to use the older GeoGebra Classic 5, which you can download at
https://wiki.geogebra.org/en/Reference:GeoGebra_Installation.

WARNING: In an effort to be user friendly, GeoGebra has created a very confusing situation with
multiple versions, and the current home page offers no clear indications about the differences
between them. GeoGebra has always combined geometry and algebra, but over the years it has added
3D graphics, a spreadsheet mode, and a basic computer algebra system (CAS). To avoid overwhelming
users, they’ve created different versions which focus on certain abilities, but this is not clearly explained.

For example, when visiting http://www.geogebra.org, you might think the Geometry app would be the
appropriate choice for this class, but that’s not true; we want the Graphing Calculator, which includes
all the geometric capabilities, but also lets us type commands, access coordinates, and so on. If you’re
installing GeoGebra on your computer, you should install Math Calculators or GeoGebra Classic 6,
which includes all of those modes.

Alternatively, you can follow the link above to download GeoGebra Classic 5, the version before this
splintering occurred. It will suffice for any of our lab assignments, and has a standard desktop application
interface; newer versions use a mobile-device interface, even on a desktop computer.

2. Getting Started

When you start GeoGebra, you will see a version of the following window. 1

1This screenshot is from the GeoGebra 5.0 Quickstart guide, available at https://app.geogebra.org/help/geogebraquickstart_en.pdf.
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The Perspectives toolbar shows you the different modes available. In general we want to choose Graphing

Calculator mode in new versions of GeoGebra, or Algebra mode in older versions. Usually you can just dismiss
this sidebar and you’ll be in the correct mode by default.

By selecting tools from the Toolbar, you can use your mouse to create things in the Drawing Pad. Equations and
coordinates for all of your points, lines, circles, and so on will be displayed in the Algebra Window. You can also
use the Input area at the bottom to create things with typed commands instead of using your mouse. Also note the
important Undo and Redo buttons!

To see how everything works, try the following steps.

(1) Select the Point tool, which looks like a point labeled with the letter A. Click two different locations in the
Drawing Pad. GeoGebra will create two points labeled A and B in the Drawing Pad. Their coordinates will
also appear in the Algebra Window.

(2) You can also create points with specific coordinates using the Input Field. Type C = (4, 1) in the Input
Field – use a capital C! – and you should see a third point appear in the Drawing Pad. If it doesn’t work,
make sure you typed everything exactly as shown, including the round parentheses.

In recent versions of GeoGebra, the Input Field is actually in the Algebra sidebar – look for
it just below A and B. This change makes the interface more consistent between the desktop
and tablet versions, but is annoying because the input field is much smaller, making it harder
to type long expressions.

(3) Now click the Polygon tool, which is the shaded triangle near the middle of the toolbar. In order, click on
A, B, C and A. GeoGebra will create a polygon (in this case, a triangle) using those points as the corners.
Notice GeoGebra automatically creates and labels the edges of the triangle. In the Algebra Window it lists
the edges and shows you the side lengths. For example, in the triangle below, the side a which is opposite
the point A is 3.06 units long.

Also notice that GeoGebra has created an object called poly1. This is the triangle itself, and its value in the
Algebra Window is the polygon’s area – 4.33 in this case.

(4) You can create polygons triangles and other shapes without creating the corners first. Still using the Polygon
tool, click four different places in the Drawing Pad and then one more time at the first point to finish your
shape. GeoGebra will create another polygon named poly2 and show you its area and its side lengths in the
Algebra Window. See below.
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(5) The Algebra Window shows “Free Objects” and “Dependent Objects.” The free objects are the ones you
created – the seven points in the Drawing Pad. The dependent objects are constructed automatically.
The power of GeoGebra is that you can change the free objects and the dependent objects will change
automatically. Try it! Choose the Move tool (the arrow / mouse cursor on the left of the toolbar), click on
point A, and drag it around.

You can also click in the middle of a polygon and drag it around. GeoGebra automatically moves the
points and updates their coordinates in the Algebra Window.

Finally, although you won’t often need to do this, you can move a point by redefining it in the Input Field.
Type A = (0, 2) (or some other coordinates), hit return, and the point and the triangle will be updated.

You may have noticed that the toolbar icons have little arrows on them. If you click on the bottom of these icons
you can choose from many more tools. Most of them are fairly self explanatory, and once you’ve chosen a tool you
can hover over its icon to read brief instructions for its use.

One of your first technology problems requires you to work with lines, rays, and intersections; to practice using
those tools try these following steps.

(1) Create a new, empty Drawing Pad by choosing File > New.

In recent versions of GeoGebra, you have to click on the ≡ symbol to access the file menu,
even on a desktop computer.

(2) A ray has a starting point and continues forever in one direction. To create a ray, choose the Ray through
Two Points tool (which is in the drop down list below the picture of a line; click where you want it to begin,
and then click again to show GeoGebra which direction the ray should extend.

(3) In the same drop down menu, choose the Segment Between Two Points tool and click on two new points
in the Drawing Pad to create a line segment. Then use the Line Between Two Points tool to create an
infinite line through two more points. Try to make the line cross your segment and your ray. If necessary,
use the Move tool to move the points around until your picture looks something like this:
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(4) Under the Point tool, select the Intersect Two Objects tool. Click on your ray and then your line.
GeoGebra should create a point G which marks the intersection of the ray and line. G is a dependent object
– you can’t change it with the Move tool. But if you move the ray or line, G will automatically change!

(5) Below the Perpendicular Line tool (the fourth icon in the toolbar) is the Parallel Line tool. Select it,
then click on A and your line through EF . GeoGebra will create a line through A which is parallel to the
line. Your Drawing Pad should resemble the following:

Use the Move tool to drag A around and see how the automatically constructed objects (like G or the
perpendicular and parallel lines) are updated.

Later in the semester you will need to use some of the more complicated transformation tools in GeoGebra. We’ll
post additional instructions online as appropriate to help you understand those tools. For now, explore with the
simpler tools in the toolbar to see what GeoGebra can do.

3. The Finer Points

To become an advanced GeoGebra user you’ll want to learn some of the finer points in this section.

Label, Names and Appearances. As you went through the instructions above, you saw that every new point
and line segment was labeled on the screen. Sometimes these labels can cover up a line segment or other object. You
can use the Move tool to click on labels and drag them around.

If your picture gets too cluttered, you might want to turn off the labels altogether. To do this, right-click on an
object and uncheck Show Label in the popup menu. Using this menu, you can also hide the object, delete it, or
rename it. If you want to avoid clutter in the future, the Options > Labeling menu gives you different options; for
example, you can tell GeoGebra to label all new points, but not the sides of any polygons you create with them.
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Right-click on a side of a polygon and choose Object Properties.2 This window lets you change a number of
things:

• Under Basic you can turn off the label or have GeoGebra display the value of the side (i.e. its length) instead
of its name. (Or both!) You can also have GeoGebra show a Caption which you type in the field above.

• Use the Color, Style and Decoration menus to change how the object looks. Note that if you want to
change all of the sides of a polygon, you should select the polygon itself. Any changes you make to the style
of a shape will be inherited by its edges.

Grid and Axes. Make sure you haven’t selected an object; you can choose the Move tool and left-click a blank
area of the drawing pad to accomplish this. Now right-click on the drawing pad and you’ll find a pop-up menu which
lets you turn the Axes and a Grid on and off. For most of your constructions you don’t need to use coordinates, so
you’ll generally want to turn both of them off. Alternatively, if you choose the Graphics option at the bottom of
the pop-up menu, you can configure the axes, tick-marks and grid.

Shortcuts. A few of the most-used tools have keyboard shortcuts. Esc will always return you to the Move tool.
Shift+Click and Drag on the Drawing Pad will slide the entire pad around. If your mouse has a scroll wheel, you
can scroll up and down to zoom out and in.

Printing. Some of the technology problems may ask you to print a sample of your GeoGebra work. You can print
a copy of the Drawing Pad from the File menu.

Screenshots. You can use the File > Export menu to copy the graphics in your Drawing Pad to the clipboard.
Then you can paste it into an email (if you’re required to send me a picture to get credit for the assignment) or into
another application, like a word processor. You can also use this menu to save your Drawing Pad to a graphics or
PDF file.

In recent versions of GeoGebra, this has been replaced with Download as... under the File

menu.

2If you can’t right-click with your mouse, you can go to Object Properties in the Edit menu and choose the side by clicking on its label
in the resulting list.
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Math 5335: Geometry GeoGebra Lab Assignment #0

Your lab assignment for this week will demonstrate that you have managed to install and use GeoGebra. You

will construct the circumcircle of a triangle; officially, we won’t cover circumcircles for weeks, but you may already

remember the concept. Given a triangle 4ABC, its circumcircle is the unique circle which passes through all three

vertices.

GeoGebra Construction

(1) Open a new GeoGebra window. Go to the View menu and turn the Grid on and the Axes off.

(2) Use the Polygon tool to create a triangle with vertices A, B and C.

(3) Choose the Perpendicular Bisector tool. Click on the line segment AB to construct its perpendicular

bisector. Repeat for BC and AC.

(4) Notice that all three perpendicular bisectors seem to intersect at the same point! Move some of the vertices

of your triangle around to verify that this is always true. Use the Intersect tool to find the intersection D

of two of the perpendicular bisectors. (In fact, the third must also pass through this point; we’ll prove this

fact in a few weeks.)

(5) Now use the Circle with Center through a Point tool to create a circle with center D which passes

through A. Amazingly, if your construction is correct, the circle will also pass through B and C. Move the

vertices around to verify that this is always the case.

To receive credit for this assignment, save your file as and email it to me as an attachment by Wednesday, 9/12/17.

The email is due by the beginning of class. You will receive full credit if all of these conditions are met:

• The subject of your email is Math 5335 Lab 0.

• Your construction is attached to the email with the filename lastname-5335-lab0.ggb, where you have

replaced the generic lastname with your own.

• I can open your file in GeoGebra, move the vertices, and verify that all of the dependent objects (triangle,

bisectors, intersection, circle) update correctly.

You might be surprised how many assignments I’ve received over the years that didn’t follow the guidelines about

the email subject line or filename. Please take the 10 seconds it takes to follow those steps!

Jonathan Rogness <rogness@math.umn.edu> September 6, 2018
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